summaryrefslogtreecommitdiff
path: root/dev-python/chump/chump-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/chump/chump-1.6.0.ebuild')
-rw-r--r--dev-python/chump/chump-1.6.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/chump/chump-1.6.0.ebuild b/dev-python/chump/chump-1.6.0.ebuild
new file mode 100644
index 000000000000..8ded5413a5ff
--- /dev/null
+++ b/dev-python/chump/chump-1.6.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# PyPy is not properly supported:
+# https://github.com/karanlyons/chump/issues/17
+PYTHON_COMPAT=( pypy3 python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="API wrapper for Pushover"
+HOMEPAGE="https://github.com/karanlyons/chump"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ # Force sphinx to use the standard theme
+ READTHEDOCS=True sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}