summaryrefslogtreecommitdiff
path: root/dev-python/cheetah3/cheetah3-3.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cheetah3/cheetah3-3.3.1.ebuild')
-rw-r--r--dev-python/cheetah3/cheetah3-3.3.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/cheetah3/cheetah3-3.3.1.ebuild b/dev-python/cheetah3/cheetah3-3.3.1.ebuild
deleted file mode 100644
index f3f6408a0e61..000000000000
--- a/dev-python/cheetah3/cheetah3-3.3.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=${P/_p/.post}
-DESCRIPTION="Python-powered template engine and code generator"
-HOMEPAGE="
- https://cheetahtemplate.org/
- https://github.com/CheetahTemplate3/Cheetah3/
- https://pypi.org/project/Cheetah3/
-"
-SRC_URI="
- https://github.com/CheetahTemplate3/Cheetah3/archive/${PV/_p/.post}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ~ppc64 ~riscv x86"
-
-RDEPEND="
- dev-python/markdown[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
-"
-
-DOCS=( ANNOUNCE.rst README.rst TODO )
-
-python_test() {
- # the package can't handle TMPDIR with hyphens
- # https://github.com/CheetahTemplate3/cheetah3/issues/53
- local -x TMPDIR=/tmp
-
- "${EPYTHON}" Cheetah/Tests/Test.py || die "Tests fail with ${EPYTHON}"
-}