summaryrefslogtreecommitdiff
path: root/dev-python/charset_normalizer/charset_normalizer-3.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/charset_normalizer/charset_normalizer-3.0.0.ebuild')
-rw-r--r--dev-python/charset_normalizer/charset_normalizer-3.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/charset_normalizer/charset_normalizer-3.0.0.ebuild b/dev-python/charset_normalizer/charset_normalizer-3.0.0.ebuild
new file mode 100644
index 000000000000..d23e9f44b22f
--- /dev/null
+++ b/dev-python/charset_normalizer/charset_normalizer-3.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The Real First Universal Charset Detector"
+HOMEPAGE="
+ https://pypi.org/project/charset-normalizer/
+ https://github.com/Ousret/charset_normalizer/
+"
+SRC_URI="
+ https://github.com/Ousret/charset_normalizer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts=
+}