summaryrefslogtreecommitdiff
path: root/dev-python/chardet
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/chardet')
-rw-r--r--dev-python/chardet/Manifest3
-rw-r--r--dev-python/chardet/chardet-3.0.4.ebuild36
-rw-r--r--dev-python/chardet/metadata.xml12
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/chardet/Manifest b/dev-python/chardet/Manifest
new file mode 100644
index 000000000000..749a07e15e60
--- /dev/null
+++ b/dev-python/chardet/Manifest
@@ -0,0 +1,3 @@
+DIST chardet-3.0.4.tar.gz 1872214 BLAKE2B b93e2d3e0b5a5c35affa5e3ee661323029f79837a1222d8f69db72911301d9490c9788d2effc577eeeb2a50334cc855afc4bdf4b8dbafb143fcc411d93b824a9 SHA512 b433ea0e15e200df968e6d61c671c42fbd77e519eb033035c4a5c241e1f98e1dfaea6747af632788507583b3ef85b00d510b3f6ef5cf58589ceca1b3a088b357
+EBUILD chardet-3.0.4.ebuild 1011 BLAKE2B f2aa7cc13f410436e07116ce3dc9ff1af005e7989cdfdce122110bc6a593cb2831074e286b88e061e9b5158e288671c489e4923c717a146807e51ef1e6b30fa3 SHA512 25c925ac055edc12c3fbaa093e695cd8aabd61351636fca2625ce4d53451576f0a69ad87a99a247d79b8b880a8961f6eb8bc6f86eac5c46f1516c7ee8e387bd3
+MISC metadata.xml 377 BLAKE2B 8aa19a889e96303024d469c969a9e47613cabd1456b0e21888a02a091049e09a53c6faa3d0e128b5ea21b68f521cede9cf09b570f2fba7a4299187a44e40b018 SHA512 c48c3874a248049fc2845d0a64ee5b94c705ef58158f882f30bbdc561f311a7203cd8979e067a5b0f3f034c95cc4b6da373cea6efc9616f3dabc574772874650
diff --git a/dev-python/chardet/chardet-3.0.4.ebuild b/dev-python/chardet/chardet-3.0.4.ebuild
new file mode 100644
index 000000000000..16910a427f31
--- /dev/null
+++ b/dev-python/chardet/chardet-3.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal encoding detector"
+HOMEPAGE="https://github.com/chardet/chardet https://pypi.org/project/chardet/"
+SRC_URI="https://github.com/chardet/chardet/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+# SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+# PyPI tarball is missing test.py: https://github.com/chardet/chardet/pull/118
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris ~amd64-fbsd"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/chardet/metadata.xml b/dev-python/chardet/metadata.xml
new file mode 100644
index 000000000000..4b05c8d0960c
--- /dev/null
+++ b/dev-python/chardet/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">chardet</remote-id>
+ <remote-id type="github">chardet/chardet</remote-id>
+ </upstream>
+</pkgmetadata>