summaryrefslogtreecommitdiff
path: root/dev-python/chameleon/chameleon-4.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/chameleon/chameleon-4.1.0.ebuild')
-rw-r--r--dev-python/chameleon/chameleon-4.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/chameleon/chameleon-4.1.0.ebuild b/dev-python/chameleon/chameleon-4.1.0.ebuild
new file mode 100644
index 000000000000..aef73bc7e9f2
--- /dev/null
+++ b/dev-python/chameleon/chameleon-4.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="
+ https://github.com/malthe/chameleon/
+ https://pypi.org/project/Chameleon/
+"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd src || die
+ distutils-r1_src_test
+}