summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.78.1.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index d2da6b1fd518..67052a34fbea 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,3 +1,5 @@
DIST cfn-lint-0.77.10.tar.gz 3488571 BLAKE2B 6b828c760bf93f1d31fe7d24d76cea63c91ed3f73837382898c4f60aea30d667b28065e4004a6fe62bee04141baa1b3baf576f30af4c823f7980d48c97e2602b SHA512 e5ca37620d33d199295d43d81c7390e181281418681fedbaaedca01a1128b8680451fba5ce429875c2242fefad8cfd234bb919fe948bbf9cdc442bb064d84972
+DIST cfn-lint-0.78.1.tar.gz 3507466 BLAKE2B 2f22cd8241eec3a26a191fc12e6e4781513e45b5ee7540d3e59d6a1f9780142ce114d3ee2ea8e05b5425a2b111dd706447045961d05e7bb3b873eb837dc98a38 SHA512 5862c3efc51e274754a5d7eba9c53a16c87933eaadc0cc8fbb2f211c07040d24d828d30922870e02bdf0758ec4417426d827ab76840332775d765714a67a3850
EBUILD cfn-lint-0.77.10.ebuild 2011 BLAKE2B 2210656075867edb6ed077388c105d77a553e2cca3255ed2284626ccf8c0d6261d8c4790f372e339d0f87c8fd508597784f42dc7ea017844561a0a4b22b8b141 SHA512 bea23a3817a02f4668209a7abb843b2b7bd904d20621fbe7dd49bbe2b87b301e27e7be3a9e83ba59e352f96020f01a9a36d09368e0ded7264dc1d00507c5fa9f
+EBUILD cfn-lint-0.78.1.ebuild 2041 BLAKE2B 7150ca8bb6fa15c89d1169460ed28d77230bc0c3ef85a390f8942126d2f91dfc45464de0060732aacba81b0facca48805eb326e48164929ec6a1aaf7bd39ce3f SHA512 0fd4d180453e5f8ddc04a0a4b0e01baf2e4c304c37243e1f945fbc5189f0e38d291611e35eaaf4f47640fed07c5d1f4034528e6307ac12307559b009f829ceae
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.78.1.ebuild b/dev-python/cfn-lint/cfn-lint-0.78.1.ebuild
new file mode 100644
index 000000000000..9c19fb3adf53
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.78.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.70.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -e '/jsonschema/s:,<4.18::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}