summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.86.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index d8b45e8677a6..53b722240c4b 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn-lint-0.85.2.tar.gz 3887432 BLAKE2B 3ae9f84d977c576b8051226b73960c97d568c5cfe4aab2030b753abd6e25b39ff2d7f2265e1edca17339ca35658808d00805ce95d3f155b395e3ed3cd84c0bdd SHA512 7c28a8f9771cb38087d30425340b95fbec637c7345cdd2c6ae2f6dc6f550cfe0b3f4cc53a60625767b40850bbf29859370cf89185bdd2a1de59a64aa43c598c3
DIST cfn-lint-0.85.3.tar.gz 3878852 BLAKE2B 4eb804c67b3cdd9686df930b7c9cc565f296a9ed99872b0d6f470c469de61d3ef321a98265c0975b32bfd2866dd66f82d2266dff77d90d31914946cafe5ce1dc SHA512 5f758664a1497b1d5260c6737e203d86ad0cd08a44067b9fdb2c4150cfafc2f96fb025322aa8573d08d6ee44254987fc7f52d6ed336944e9e2a89fc174d8db6c
+DIST cfn-lint-0.86.0.tar.gz 3847186 BLAKE2B 8edc25b25bd385717f7c1cd7d79cc910ec87c5232daec70cd448659e56cd710524532b66e3392d369b787765613a83bf37180f5f64bd489ec9c32d24cb6a3963 SHA512 4dc131c2cfc2d9892c6835a505bc5cc9a3d570cc22750bbb239b577417b010de7cfd0b17caeae44197b2cecbdf163973e447906eae778aba84834ebce3b5d0b3
EBUILD cfn-lint-0.85.2.ebuild 2065 BLAKE2B e8a272d09d264c38ae551f293b660518740fde7a9dbc2be449855053ebf79460c0aa396a670ad8a351f4a30f7c7588e133009c86581455ec9b53066b730aeb73 SHA512 cae80015c294a1c3cdadcd5ab99df82d656cfb8d8c55f9464d7dd0e2107d82a70e0daf6dbae758e3dbcdf599905328fb3b395081b5c8c0307509e4a500b092b3
EBUILD cfn-lint-0.85.3.ebuild 2068 BLAKE2B 374c07174fac5329d07d96b15cf9eda071d38d234461d89e9b925c2da8d106bb474b94e7faa9ccb90ecf9dc359a6d22e72d43550b2e8a4b95df6664c097ce415 SHA512 960910c586ea618e865a265bb3dee1424c404ca7fd0f4d52cba6c7947850ecb44d72fd9bab063caa5e97fd024daf9f723990f35db62446edcbc61198fe79f116
+EBUILD cfn-lint-0.86.0.ebuild 2068 BLAKE2B 374c07174fac5329d07d96b15cf9eda071d38d234461d89e9b925c2da8d106bb474b94e7faa9ccb90ecf9dc359a6d22e72d43550b2e8a4b95df6664c097ce415 SHA512 960910c586ea618e865a265bb3dee1424c404ca7fd0f4d52cba6c7947850ecb44d72fd9bab063caa5e97fd024daf9f723990f35db62446edcbc61198fe79f116
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.86.0.ebuild b/dev-python/cfn-lint/cfn-lint-0.86.0.ebuild
new file mode 100644
index 000000000000..9a00ccdd992c
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.86.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.85.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}