summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.86.4.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 6f95e99e62b7..dcfa91339267 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn-lint-0.86.2.tar.gz 3918328 BLAKE2B c46528a4de5ae26554a5c7099ac87c7b5984bd3b7c602f87991b441b7678442202f9a669814b356efe8dbf9287e7f911ccf6641bb738d0900a9e059915ee536e SHA512 a7f7ce49ea2acfa5c32057ae01c1ed4cf8b9e8caee854ee91a6631b200c289e9cf2169d918fe997ad44f0ab21507894e5d6c5f18a06f563373384da003a139f4
DIST cfn_lint-0.86.3.tar.gz 3909137 BLAKE2B 8fa9e895c444935e655e64b123c0506216640905da4cd133c01ff996fdbccfe02c61f0aa3c96bfc3153084219ded432670cb1482c59c286094c7eade6c548c94 SHA512 a2b93339ad2ed89773c84370953a03c55d09ab421ce2cc4f40d08df7a4fa810a1041c4925a376e4a742be987d4021085a8bc96c56bd65a519f57104dc2c93f62
+DIST cfn_lint-0.86.4.tar.gz 3911739 BLAKE2B ea2d58abb78b466371b5a65cda2f5fd06f31eb16eece4d5bb3741f166e0bfb54d35c5d6605f5d9b333876fa1a85916f0aaecab5f0b0bd6b29841a2b5e813ed09 SHA512 71b50058ccdbcccedc92b70ca1af4c5163feb26415a97afad6e39761645423259b4dcdb6a24b517ba494e7474b31909d44399461c6d19834791d5057b14ef886
EBUILD cfn-lint-0.86.2.ebuild 2065 BLAKE2B ef82ff0209bf4b10853eb3a02930843e2271597211e78b889741fdd897a952a0af7e251db479ef173205d66686057005bad60d10bdbb46d97f76b682955762f8 SHA512 561ef033f4a4eb78fc4407c1a4b69a6a823abe1c9c976867f81e031add88205cb2c3f8a4c72a976a72172f37d85534ae3a646ece87532e41e587fe2524623232
EBUILD cfn-lint-0.86.3.ebuild 2048 BLAKE2B bfe0feed062cf5ab237eda74e93c26a793e499e46c843ddbe16f7dee814d2714de1bf7ec71452c7e45e053c744423455da4c00b16e35aa94a3168c01b15c3b74 SHA512 a4f970973f0faf279a6af11074eabbd47f410aeb7d24d0e10dbf232f426a6ecccc61d7336dd787941e76ff966dc9b075f6614b45064c6ddcc524299d4cb76e87
+EBUILD cfn-lint-0.86.4.ebuild 2048 BLAKE2B bfe0feed062cf5ab237eda74e93c26a793e499e46c843ddbe16f7dee814d2714de1bf7ec71452c7e45e053c744423455da4c00b16e35aa94a3168c01b15c3b74 SHA512 a4f970973f0faf279a6af11074eabbd47f410aeb7d24d0e10dbf232f426a6ecccc61d7336dd787941e76ff966dc9b075f6614b45064c6ddcc524299d4cb76e87
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.86.4.ebuild b/dev-python/cfn-lint/cfn-lint-0.86.4.ebuild
new file mode 100644
index 000000000000..ccd32235036e
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.86.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.87.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}