summaryrefslogtreecommitdiff
path: root/dev-python/cfn-lint
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cfn-lint')
-rw-r--r--dev-python/cfn-lint/Manifest2
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.86.2.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 1b5f10e02367..efee68b8d3a0 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,5 +1,7 @@
DIST cfn-lint-0.86.0.tar.gz 3847186 BLAKE2B 8edc25b25bd385717f7c1cd7d79cc910ec87c5232daec70cd448659e56cd710524532b66e3392d369b787765613a83bf37180f5f64bd489ec9c32d24cb6a3963 SHA512 4dc131c2cfc2d9892c6835a505bc5cc9a3d570cc22750bbb239b577417b010de7cfd0b17caeae44197b2cecbdf163973e447906eae778aba84834ebce3b5d0b3
DIST cfn-lint-0.86.1.tar.gz 3865324 BLAKE2B b5b31d12dde1e0d5d3f8da42cf22bb6cc7c2a6b87f12edc3bdbaed5b51da013f24c58ce4cb2a6e0a412ba153b15f6ac46cce194f9617bd493041d922025ba067 SHA512 b396b68a93782e018b0690dc33430d4f013d597f78e66218af3058fd97c766e4c36ab5d78a0b620b0838b55e6197bef66580f1c3cd98320ddd29ec1ff91bd6c2
+DIST cfn-lint-0.86.2.tar.gz 3918328 BLAKE2B c46528a4de5ae26554a5c7099ac87c7b5984bd3b7c602f87991b441b7678442202f9a669814b356efe8dbf9287e7f911ccf6641bb738d0900a9e059915ee536e SHA512 a7f7ce49ea2acfa5c32057ae01c1ed4cf8b9e8caee854ee91a6631b200c289e9cf2169d918fe997ad44f0ab21507894e5d6c5f18a06f563373384da003a139f4
EBUILD cfn-lint-0.86.0.ebuild 2065 BLAKE2B d8d56f70cae70db7c7f15f56b9076cdc1b6e8bb48d6341e2786d02ceeec7405387fba1fcfa4ac4b2bab9c6613febe58b62abf29d90ab23b58f28cc99d029cfa5 SHA512 fea68f9baa2f13a92ca79b9f25e679c54e55375e9b1b58ec25212d9078e8c0a5f34f068dccdab87f92928fe65f89e09689ca0064ca5655373a14ad391025a6c9
EBUILD cfn-lint-0.86.1.ebuild 2068 BLAKE2B b3446ded957c9821bb8bf0eed072ea66ed5e109e9d34683f08d7387350752cf7fc539cbefe7216c744a5e3a747b72193d3aaaa2f03616f468b117f9f97d37092 SHA512 1053e631c111fd5e7f9e7fca6f2e917ee96ac2bc3cf50e17e0d5f8334769bba689888ea7b999c09b90a76696d3a7e3f4ff516524bc761a563188e20e5c82ab41
+EBUILD cfn-lint-0.86.2.ebuild 2068 BLAKE2B b3446ded957c9821bb8bf0eed072ea66ed5e109e9d34683f08d7387350752cf7fc539cbefe7216c744a5e3a747b72193d3aaaa2f03616f468b117f9f97d37092 SHA512 1053e631c111fd5e7f9e7fca6f2e917ee96ac2bc3cf50e17e0d5f8334769bba689888ea7b999c09b90a76696d3a7e3f4ff516524bc761a563188e20e5c82ab41
MISC metadata.xml 583 BLAKE2B 9f73e2b92e5cfa2ad59f5c8e5d91bdd3aa9eba3fa722b93b388cffea42020db7e7441bab5749432812934a4514d3e9104e6d897e1d115afa5ed237757bd48c03 SHA512 1866a349855ae4e248498b7aabd6ce4c4e10ea58731df4bfa13500f61dc041da6dbd7420e7d6a78fad46d5cf00bd7ef2d0c4c7d6819a21b3a5031b0d49588a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.86.2.ebuild b/dev-python/cfn-lint/cfn-lint-0.86.2.ebuild
new file mode 100644
index 000000000000..1ace14e6286b
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.86.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.86.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ <dev-python/networkx-4[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/regex-2021.7.1[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/sympy-1.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+ # TODO: it looks as if AWS_DEFAULT_REGION didn't work
+ test/unit/module/core/test_run_cli.py::TestCli::test_bad_config
+ test/unit/module/core/test_run_cli.py::TestCli::test_override_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_positional_template_parameters
+ test/unit/module/core/test_run_cli.py::TestCli::test_template_config
+ )
+
+ # from tox.ini
+ local -x AWS_DEFAULT_REGION=us-east-1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}