summaryrefslogtreecommitdiff
path: root/dev-python/catkin_pkg/catkin_pkg-0.4.23-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/catkin_pkg/catkin_pkg-0.4.23-r1.ebuild')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.4.23-r1.ebuild21
1 files changed, 5 insertions, 16 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.4.23-r1.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.4.23-r1.ebuild
index 5a64a0e6f182..79e5eb6b91bf 100644
--- a/dev-python/catkin_pkg/catkin_pkg-0.4.23-r1.ebuild
+++ b/dev-python/catkin_pkg/catkin_pkg-0.4.23-r1.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8,3_9} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
SCM=""
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -24,27 +24,18 @@ fi
LICENSE="BSD"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
-"
+ !<dev-util/catkin-0.7.14"
BDEPEND="
test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-DEPEND="${RDEPEND} ${BDEPEND}
- test? (
dev-python/flake8[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)"
-RDEPEND="${RDEPEND}
- !<dev-util/catkin-0.7.14"
+
PATCHES=(
"${FILESDIR}/catkin_prefix2.patch"
"${FILESDIR}/ros_packages.patch"
@@ -52,6 +43,4 @@ PATCHES=(
"${FILESDIR}/summary_single_line.patch"
)
-python_test() {
- nosetests -s --tests test || die
-}
+distutils_enable_tests nose