summaryrefslogtreecommitdiff
path: root/dev-python/capturer/capturer-2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/capturer/capturer-2.3.ebuild')
-rw-r--r--dev-python/capturer/capturer-2.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/capturer/capturer-2.3.ebuild b/dev-python/capturer/capturer-2.3.ebuild
new file mode 100644
index 000000000000..8a2d9f16e3a0
--- /dev/null
+++ b/dev-python/capturer/capturer-2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily capture stdout/stderr of the current process and subprocesses"
+HOMEPAGE="https://capturer.readthedocs.org/ https://pypi.org/project/capturer/ https://github.com/xolox/python-capturer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/humanfriendly-2.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+# Test fails only ebuild, but works manually
+# Can't find out what it is
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}