summaryrefslogtreecommitdiff
path: root/dev-python/cachelib/cachelib-0.10.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cachelib/cachelib-0.10.2-r1.ebuild')
-rw-r--r--dev-python/cachelib/cachelib-0.10.2-r1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/cachelib/cachelib-0.10.2-r1.ebuild b/dev-python/cachelib/cachelib-0.10.2-r1.ebuild
deleted file mode 100644
index 6b8356cd97d6..000000000000
--- a/dev-python/cachelib/cachelib-0.10.2-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of cache libraries in the same API interface. Extracted from werkzeug"
-HOMEPAGE="
- https://pypi.org/project/cachelib/
- https://github.com/pallets-eco/cachelib/
-"
-SRC_URI="
- https://github.com/pallets-eco/cachelib/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pylibmc[${PYTHON_USEDEP}]
- dev-python/pytest-xprocess[${PYTHON_USEDEP}]
- dev-python/redis[${PYTHON_USEDEP}]
- net-misc/memcached
- www-servers/uwsgi[python,${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # bug #818523
- tests/test_redis_cache.py
- # requires some test server running
- # (these tests require dev-python/boto3)
- tests/test_dynamodb_cache.py
-)