summaryrefslogtreecommitdiff
path: root/dev-python/bsddb3/bsddb3-6.2.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bsddb3/bsddb3-6.2.7.ebuild')
-rw-r--r--dev-python/bsddb3/bsddb3-6.2.7.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/bsddb3/bsddb3-6.2.7.ebuild b/dev-python/bsddb3/bsddb3-6.2.7.ebuild
index 2636c7c14f52..d217d17a5f11 100644
--- a/dev-python/bsddb3/bsddb3-6.2.7.ebuild
+++ b/dev-python/bsddb3/bsddb3-6.2.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
PYTHON_REQ_USE="threads(+)"
DISTUTILS_USE_SETUPTOOLS=no
@@ -27,11 +27,14 @@ RDEPEND="
sys-libs/db:4.8
sys-libs/db:4.7
)"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
DISTUTILS_IN_SOURCE_BUILD=1
+PATCHES=(
+ "${FILESDIR}"/${P}-py39.patch
+)
+
python_prepare_all() {
# This list should be kept in sync with setup.py.
if [[ -z ${DB_VER} ]]; then