summaryrefslogtreecommitdiff
path: root/dev-python/braintree/braintree-4.23.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/braintree/braintree-4.23.0.ebuild')
-rw-r--r--dev-python/braintree/braintree-4.23.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/braintree/braintree-4.23.0.ebuild b/dev-python/braintree/braintree-4.23.0.ebuild
index c50e26d97b9e..06d433d74228 100644
--- a/dev-python/braintree/braintree-4.23.0.ebuild
+++ b/dev-python/braintree/braintree-4.23.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -34,6 +34,11 @@ DOCS=( README.md )
distutils_enable_tests unittest
+PATCHES=(
+ # https://github.com/braintree/braintree_python/pull/154
+ "${FILESDIR}/${P}-py312.patch"
+)
+
python_test() {
eunittest tests/unit
}