summaryrefslogtreecommitdiff
path: root/dev-python/bpython/bpython-0.21.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bpython/bpython-0.21.ebuild')
-rw-r--r--dev-python/bpython/bpython-0.21.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/bpython/bpython-0.21.ebuild b/dev-python/bpython/bpython-0.21.ebuild
index b89b73167409..d815d9186569 100644
--- a/dev-python/bpython/bpython-0.21.ebuild
+++ b/dev-python/bpython/bpython-0.21.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
@@ -34,7 +32,10 @@ BDEPEND="
DOCS=( AUTHORS.rst CHANGELOG.rst )
-PATCHES=( "${FILESDIR}"/${PN}-sphinx-4.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-sphinx-4.patch
+ "${FILESDIR}"/${P}-fix-py3.10.patch
+)
distutils_enable_sphinx doc/sphinx/source --no-autodoc
distutils_enable_tests unittest