summaryrefslogtreecommitdiff
path: root/dev-python/bottleneck/bottleneck-1.3.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bottleneck/bottleneck-1.3.2-r1.ebuild')
-rw-r--r--dev-python/bottleneck/bottleneck-1.3.2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/bottleneck/bottleneck-1.3.2-r1.ebuild b/dev-python/bottleneck/bottleneck-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..17698378620b
--- /dev/null
+++ b/dev-python/bottleneck/bottleneck-1.3.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast NumPy array functions written in C"
+HOMEPAGE="https://pypi.org/project/Bottleneck/"
+SRC_URI="https://github.com/kwgoodman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/numpy-1.9.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ "${EPYTHON}" ./tools/test-installed-bottleneck.py -vv -m full || die
+}