summaryrefslogtreecommitdiff
path: root/dev-python/bottleneck/bottleneck-1.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bottleneck/bottleneck-1.2.1.ebuild')
-rw-r--r--dev-python/bottleneck/bottleneck-1.2.1.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/bottleneck/bottleneck-1.2.1.ebuild b/dev-python/bottleneck/bottleneck-1.2.1.ebuild
deleted file mode 100644
index 6221eaf82420..000000000000
--- a/dev-python/bottleneck/bottleneck-1.2.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fast NumPy array functions written in Cython"
-HOMEPAGE="https://pypi.org/project/Bottleneck/"
-SRC_URI="https://github.com/kwgoodman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/numpy-1.9.1[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose )"
-
-python_test() {
- ${EPYTHON} ./tools/test-installed-bottleneck.py
-}