summaryrefslogtreecommitdiff
path: root/dev-python/botocore/botocore-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/botocore/botocore-9999.ebuild')
-rw-r--r--dev-python/botocore/botocore-9999.ebuild8
1 files changed, 2 insertions, 6 deletions
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index 5894fd995097..7cacb5c3f634 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -61,12 +61,8 @@ python_test() {
# rely on bundled six
tests/functional/test_six_imports.py::test_no_bare_six_imports
tests/functional/test_six_threading.py::test_six_thread_safety
- # fails on unrelated warnings
- tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
- tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
- # TODO
- tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
)
- epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit} -p xdist -n "$(makeopts_jobs)"
}