summaryrefslogtreecommitdiff
path: root/dev-python/botocore/botocore-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/botocore/botocore-9999.ebuild')
-rw-r--r--dev-python/botocore/botocore-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index f9ce3c85acf8..54136d6d4829 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -45,6 +45,10 @@ PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
python_compile_all() {
use doc && emake -C docs html
+
+ # remove version locked deps
+ sed -r -e 's:([a-zA-Z0-9_-]+)[><|=].*:\1:' \
+ -i requirements.txt || die
}
python_test() {