summaryrefslogtreecommitdiff
path: root/dev-python/botocore/botocore-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/botocore/botocore-9999.ebuild')
-rw-r--r--dev-python/botocore/botocore-9999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index 35239170e3a4..a1a5a4e1ea37 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -5,10 +5,14 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
+
inherit distutils-r1 multiprocessing
DESCRIPTION="Low-level, data-driven core of boto 3"
-HOMEPAGE="https://github.com/boto/botocore"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
LICENSE="Apache-2.0"
SLOT="0"
@@ -22,7 +26,7 @@ fi
RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
- dev-python/jmespath[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
"
@@ -62,6 +66,5 @@ python_test() {
tests/functional/test_six_threading.py::test_six_thread_safety
)
- epytest tests/{functional,unit} \
- -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
}