summaryrefslogtreecommitdiff
path: root/dev-python/botocore/botocore-1.8.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/botocore/botocore-1.8.6.ebuild')
-rw-r--r--dev-python/botocore/botocore-1.8.6.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/botocore/botocore-1.8.6.ebuild b/dev-python/botocore/botocore-1.8.6.ebuild
index 8ec458cb0679..08b1d49616cb 100644
--- a/dev-python/botocore/botocore-1.8.6.ebuild
+++ b/dev-python/botocore/botocore-1.8.6.ebuild
@@ -38,12 +38,15 @@ DEPEND="
"
RDEPEND="${CDEPEND}"
+PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
- nosetests -v tests/unit tests/functional || die "tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
}
python_install_all() {