summaryrefslogtreecommitdiff
path: root/dev-python/botocore/botocore-1.15.48.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/botocore/botocore-1.15.48.ebuild')
-rw-r--r--dev-python/botocore/botocore-1.15.48.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/botocore/botocore-1.15.48.ebuild b/dev-python/botocore/botocore-1.15.48.ebuild
index 1c38902f7a11..cc5f5d311549 100644
--- a/dev-python/botocore/botocore-1.15.48.ebuild
+++ b/dev-python/botocore/botocore-1.15.48.ebuild
@@ -43,6 +43,13 @@ DEPEND="
PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
+src_prepare() {
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
python_compile_all() {
use doc && emake -C docs html
}