summaryrefslogtreecommitdiff
path: root/dev-python/boto3
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest2
-rw-r--r--dev-python/boto3/boto3-1.34.80.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 738031feb7bd..f8a096d26b32 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,7 +1,9 @@
DIST boto3-1.34.69.gh.tar.gz 787293 BLAKE2B 9e46a959f3efdc3e673d38c8e3c30b8ceed1c1f47d685466e4164bcc1000381710bf8d8b6afff0999185ccddf38da591df004c54709729f2181308cb2279c43f SHA512 ef765518de95468e66270cea6dc93ede48547fb37db3ed9429659d85fb25174162cd062814c6adefeb8385c14079e7927f52d66501ab45f8d251ccfc830465e4
DIST boto3-1.34.74.gh.tar.gz 790202 BLAKE2B 4368db3e11d6bda6eee4ccde82bcc0c2c5a67448400ce0d29d221840360348ab1c7d3c8360ff3c91190ebccb30e187c6fc3ed72f29f1a1d1f883888a8cad12dc SHA512 977e1b9f8a9506bd040ff6a9a1df106294ff62a100cf5cb31aeaa363a4f3fe28cab71e4740028202829fac3023bf832bd4ac25b3474c2a5e107892c05b356e0c
DIST boto3-1.34.79.gh.tar.gz 792796 BLAKE2B 97a4f8e6fc33bcfe2817ce353df8ff6354bc89c449e5e29833704e12513aa21129863164c51047b17c7f15a47f0ceb90c60a83071464283292089b2535e8fed9 SHA512 15161face918253eac06dfbeb67adb8ef5ed6902b2eed760feb9fdd3aee0e38da3511aa7d829914b6f80addff7feffae7d3645f7567643a37d3659001d7b6a1a
+DIST boto3-1.34.80.gh.tar.gz 793186 BLAKE2B aa45147344c21291f413580473bdd358d25e69944c16ea43e731465911c5c16fdc1e9fde20d69634debdc7cd0af07a999072ee6ecfb6c0b93a96ecb66dee78b3 SHA512 a43be78c98060a0aeb232dad7bb118768711e375f8137d0b59293397056a360a6a6e7d067651404c4ae43180d9c5e100fd2ee041b8ecc17e9982a30cdfc0e8d4
EBUILD boto3-1.34.69.ebuild 1258 BLAKE2B 7f7ba2672f66400a4c2c202847d4bc7b57a0941b51f4f2f725475c38b6092c6a89687476db8bb701688ff47ccce491ffc435968a407ffc30ef860747573a1f43 SHA512 aebf347c928b4364a045a4bfb20edad39f9530fed5dfeef6b7e684feae0a146b71aa53cbb49f0b79e89671b97402aad447e6971df74ee44fef523ebad23f992c
EBUILD boto3-1.34.74.ebuild 1265 BLAKE2B ba7f54112a52fbd951c886d41b7deb5820caefe05c87f7cdf2564e8cdab75359bd0dcde93be72c588c3422ef1b69043daa8d9ffee43da72efcc9e522814396da SHA512 0fb5d2d3bd9f8fd424837df59aaaad023777459818141a3171f747bacdae21f81cac690da36af13123f20acf5a46d6edb90f76afe0773915526d4a816dea510d
EBUILD boto3-1.34.79.ebuild 1205 BLAKE2B 27d096dc4f88c8351e0857e9f8b4195060f3f1218e1734c699a832246cc59e081cda9ee7369e3b44706e7ce8ef390e8792e273aff7f6e92a75c69461fc1136d6 SHA512 cca4aef410e4fb2ef71181a15233da830df39d8b7f1e779b5d6a8df74eb602afee11b8965e0ca9254cb87155a8514b43fcc0de09f681ecec9a384a904f3fe0b2
+EBUILD boto3-1.34.80.ebuild 1205 BLAKE2B 27d096dc4f88c8351e0857e9f8b4195060f3f1218e1734c699a832246cc59e081cda9ee7369e3b44706e7ce8ef390e8792e273aff7f6e92a75c69461fc1136d6 SHA512 cca4aef410e4fb2ef71181a15233da830df39d8b7f1e779b5d6a8df74eb602afee11b8965e0ca9254cb87155a8514b43fcc0de09f681ecec9a384a904f3fe0b2
MISC metadata.xml 493 BLAKE2B 7d6324fc877ffe1d20c5369c2af0b09a7028f94d28f1841188913d0d8be7ea699c9d3f92c624992c4c96bd69615d3a1211a2483c76c56b7d3082492e43512523 SHA512 44420d8c03d5986f990b76369edfa8dfd7659b4952db3ad946fd05392ec594628a28745ad888d055d4f074d5214f61fcffafe6c04c4ab54109d45ac0371582bd
diff --git a/dev-python/boto3/boto3-1.34.80.ebuild b/dev-python/boto3/boto3-1.34.80.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.80.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}