summaryrefslogtreecommitdiff
path: root/dev-python/blurb/blurb-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/blurb/blurb-1.2.0.ebuild')
-rw-r--r--dev-python/blurb/blurb-1.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/blurb/blurb-1.2.0.ebuild b/dev-python/blurb/blurb-1.2.0.ebuild
new file mode 100644
index 000000000000..ed8b87d5b515
--- /dev/null
+++ b/dev-python/blurb/blurb-1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tool to create and manage NEWS blurbs for CPython"
+HOMEPAGE="
+ https://github.com/python/core-workflow/tree/master/blurb
+ https://pypi.org/project/blurb/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest