summaryrefslogtreecommitdiff
path: root/dev-python/blosc/blosc-1.4.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/blosc/blosc-1.4.4.ebuild')
-rw-r--r--dev-python/blosc/blosc-1.4.4.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/blosc/blosc-1.4.4.ebuild b/dev-python/blosc/blosc-1.4.4.ebuild
deleted file mode 100644
index 2fa9aa3ba29d..000000000000
--- a/dev-python/blosc/blosc-1.4.4.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="High performance compressor optimized for binary data"
-HOMEPAGE="http://python-blosc.blosc.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-libs/c-blosc:="
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- export BLOSC_DIR="${EPREFIX}/usr"
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- nosetests -v || die
-}