summaryrefslogtreecommitdiff
path: root/dev-python/blosc/blosc-1.11.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/blosc/blosc-1.11.1.ebuild')
-rw-r--r--dev-python/blosc/blosc-1.11.1.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/dev-python/blosc/blosc-1.11.1.ebuild b/dev-python/blosc/blosc-1.11.1.ebuild
index a6135a6ca9c4..560554b6dde2 100644
--- a/dev-python/blosc/blosc-1.11.1.ebuild
+++ b/dev-python/blosc/blosc-1.11.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1
@@ -22,8 +22,8 @@ SRC_URI="
"
S=${WORKDIR}/${MY_P}
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -45,11 +45,24 @@ BDEPEND="
DOCS=( ANNOUNCE.rst README.rst RELEASE_NOTES.rst )
+PATCHES=(
+ # https://github.com/Blosc/python-blosc/pull/329
+ "${FILESDIR}/${P}-numpy-2.patch"
+)
+
src_configure() {
export USE_SYSTEM_BLOSC=1
export BLOSC_DIR="${EPREFIX}/usr"
}
+python_compile() {
+ distutils-r1_python_compile
+
+ # scikit-build is broken and reuses the same build
+ # https://github.com/scikit-build/scikit-build/issues/633
+ rm -r _skbuild || die
+}
+
python_test() {
"${EPYTHON}" -m blosc.test -v || die
}