summaryrefslogtreecommitdiff
path: root/dev-python/blinker/blinker-1.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/blinker/blinker-1.7.0.ebuild')
-rw-r--r--dev-python/blinker/blinker-1.7.0.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/blinker/blinker-1.7.0.ebuild b/dev-python/blinker/blinker-1.7.0.ebuild
index caa91f2b57eb..c965ec466d37 100644
--- a/dev-python/blinker/blinker-1.7.0.ebuild
+++ b/dev-python/blinker/blinker-1.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,4 +18,15 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}