summaryrefslogtreecommitdiff
path: root/dev-python/bleach/bleach-3.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bleach/bleach-3.0.2.ebuild')
-rw-r--r--dev-python/bleach/bleach-3.0.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/bleach/bleach-3.0.2.ebuild b/dev-python/bleach/bleach-3.0.2.ebuild
new file mode 100644
index 000000000000..3ae4009d0bb5
--- /dev/null
+++ b/dev-python/bleach/bleach-3.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="https://github.com/mozilla/bleach https://pypi.org/project/bleach/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -v || die "tests failed under ${EPYTHON}"
+}