summaryrefslogtreecommitdiff
path: root/dev-python/bleach/bleach-2.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bleach/bleach-2.1.3.ebuild')
-rw-r--r--dev-python/bleach/bleach-2.1.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/bleach/bleach-2.1.3.ebuild b/dev-python/bleach/bleach-2.1.3.ebuild
new file mode 100644
index 000000000000..7d6101cf43a6
--- /dev/null
+++ b/dev-python/bleach/bleach-2.1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="https://github.com/mozilla/bleach https://pypi.python.org/pypi/bleach"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/html5lib-0.99999999[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/pytest-3.0.3[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v || die "tests failed under ${EPYTHON}"
+}