summaryrefslogtreecommitdiff
path: root/dev-python/bitstring/bitstring-4.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bitstring/bitstring-4.1.0.ebuild')
-rw-r--r--dev-python/bitstring/bitstring-4.1.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/bitstring/bitstring-4.1.0.ebuild b/dev-python/bitstring/bitstring-4.1.0.ebuild
deleted file mode 100644
index e858ce76a9a1..000000000000
--- a/dev-python/bitstring/bitstring-4.1.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A pure Python module for creation and analysis of binary data"
-HOMEPAGE="
- https://github.com/scott-griffiths/bitstring/
- https://pypi.org/project/bitstring/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-
-RDEPEND="
- >=dev-python/bitarray-2.8.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # sigh
- sed -i -e 's:==:>=:' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # seriously, how obtrusive can you be?
- tests/test_bitstring.py::ModuleData::testVersion
- )
-
- epytest
-}