summaryrefslogtreecommitdiff
path: root/dev-python/bcrypt/bcrypt-3.1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/bcrypt/bcrypt-3.1.6.ebuild')
-rw-r--r--dev-python/bcrypt/bcrypt-3.1.6.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-python/bcrypt/bcrypt-3.1.6.ebuild b/dev-python/bcrypt/bcrypt-3.1.6.ebuild
deleted file mode 100644
index e1a364efcd6c..000000000000
--- a/dev-python/bcrypt/bcrypt-3.1.6.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Modern password hashing for software and servers"
-HOMEPAGE="https://github.com/pyca/bcrypt/ https://pypi.org/project/bcrypt/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="
- $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
- >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
-"
-DEPEND="${COMMON_DEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/pytest-3.2.1[${PYTHON_USEDEP}] )
-"
-RDEPEND="${COMMON_DEPEND}
- !dev-python/py-bcrypt"
-
-python_test() {
- esetup.py test
-}