summaryrefslogtreecommitdiff
path: root/dev-python/basho-erlastic/basho-erlastic-2.1.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/basho-erlastic/basho-erlastic-2.1.1-r1.ebuild')
-rw-r--r--dev-python/basho-erlastic/basho-erlastic-2.1.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/basho-erlastic/basho-erlastic-2.1.1-r1.ebuild b/dev-python/basho-erlastic/basho-erlastic-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..983e8fe7fba3
--- /dev/null
+++ b/dev-python/basho-erlastic/basho-erlastic-2.1.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Erlang binary term codec and port interface"
+HOMEPAGE="
+ https://github.com/basho/python-erlastic/
+ https://pypi.org/project/basho-erlastic/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" tests.py || die
+}