summaryrefslogtreecommitdiff
path: root/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.3.ebuild')
-rw-r--r--dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.3.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.3.ebuild b/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.3.ebuild
deleted file mode 100644
index e04f64b8b5e1..000000000000
--- a/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-MY_PN="${MY_PN//-/_}"
-DESCRIPTION="Backport of functools.lru_cache from Python 3.3"
-HOMEPAGE="https://github.com/jaraco/backports.functools_lru_cache"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/rst-linker[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- distutils-r1_python_install_all
-}