summaryrefslogtreecommitdiff
path: root/dev-python/autopep8
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest4
-rw-r--r--dev-python/autopep8/autopep8-2.0.4_p20231027.ebuild51
-rw-r--r--dev-python/autopep8/autopep8-2.1.0.ebuild2
3 files changed, 2 insertions, 55 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 8eafddc390ea..fae46cfd4484 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,6 +1,4 @@
-DIST autopep8-2.0.4_p20231027.gh.tar.gz 146180 BLAKE2B 3818423c9683157df0c3ed905a225228da7ca44a361247aecbc84b70bd5476a148c6ceb38598b84ff337bf66b1fadcbec47c79738954d90fe1f04f31a467441a SHA512 28c88acd0863d7f6a7333150ce9b916e4776eefacc7eeb7c4de14a3c823c9331fb15fef03f2288ae921ddef37c19191a6550b152df6331d075217908ab1b3a7f
DIST autopep8-2.1.0.tar.gz 88891 BLAKE2B 60bd5e9a177d8bdb741b37884bb3ef170fb59664b740beb1b1f38df021dfb7916f2cecdb2e20b6363c2abcc110f9f36902dbccd7f06ddf56f090ccb36149fb19 SHA512 f694a506646b4bc4932fb07cf1c989897e7db3fc9b65dc90886fa657b163dfcbad4c16bb911a2e399a4623b167b313d32213762d3e21e20bff27b6fe2a5abc59
-EBUILD autopep8-2.0.4_p20231027.ebuild 1299 BLAKE2B 0d4ffd764f986be8fa97d2e32191f197cf8f2d76b1f4b544e14697451cbcd21834c386f5725672ed172f9e4d9de9fe92bb27446b08e8fede1c0b8aad230bd230 SHA512 79343564c5fe8bf2116bf36b88a939fdfe64a77c014e33c1afc440ef61fd2c57cd8fb9da2c4fa115d3642eecc7fe7d31d05f279f42de9f8f822923f946d97595
-EBUILD autopep8-2.1.0.ebuild 688 BLAKE2B 44cb4f20afa19f4db796bdfca113c4a6bad1737432cf5372838abc090400fb48b593e4cf80f60f073f620b205d60aab0223a7621eb198f8cb7be7a4fe42db657 SHA512 a42c73e1532a8b2beedeb6bd231e3e6413790b8bde9b983e3f9a3eeb03912e79872d2bb202ecbe4dbde28070e6ecbdf69c2300093fbad92ee6eeaabdccb52777
+EBUILD autopep8-2.1.0.ebuild 683 BLAKE2B 7fd570789b4f70426e6f8994423f48c0d9c98fd7c9a2f55427d7a716d44b1b6d94d6d32a443655974a6be999ec2a56d799bc961218b38faf2b6e7be512d05451 SHA512 128abd0cb5b923d52a9ba88d5594c9dc12e6e1ad6cd76bd1a2e57d4aa74b4b5454f60bfcd9227c667d8675a87a31b8f610dd0ea340ca3693db81a67c9647ce0c
EBUILD autopep8-9999.ebuild 804 BLAKE2B 639958a931b30f46cab9c6f28845f221f7bbd3a32101418cb442bc2b37a1ee5c843a409c16370e04ce1fd9188eda006d2ed6d32d22fbbd13a46191a55efb540d SHA512 2de23197bb23add952003d6ebb737fd346b58897ffca8f11caa98e4e5de88b412dbdbcf84bc374f22db10d75a520796b07a3c7af3cb3cb48c9a64a419f0ca2da
MISC metadata.xml 404 BLAKE2B e9442968d195e1605d55b880cf29f4a2945f67c57c0d7d0325e19c0ccf60cac0ac3e68115a0285f87068482163f537abc1d75bddfdc6ae860c8c52c375147fdc SHA512 3e0b8a6ee869086166bb670a73189ca681729276cc7897666127b7e25b3a252aa2e80da5fd4dbb43d101a439d12f146ba0ba61bebf30a87a97f1030325f1aeab
diff --git a/dev-python/autopep8/autopep8-2.0.4_p20231027.ebuild b/dev-python/autopep8/autopep8-2.0.4_p20231027.ebuild
deleted file mode 100644
index 81dbf312a6ed..000000000000
--- a/dev-python/autopep8/autopep8-2.0.4_p20231027.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="
- https://github.com/hhatto/autopep8/
- https://pypi.org/project/autopep8/
-"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
- inherit git-r3
-else
- KEYWORDS="~alpha amd64 arm64 ~ia64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
- COMMIT="af7399d90926f2fe99a71f15197a08fa197f73a1"
- SRC_URI="
- https://github.com/hhatto/autopep8/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz
- "
- S="${WORKDIR}/${PN}-${COMMIT}"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/pycodestyle-2.10[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.10)
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=()
-
- [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
- # fails due to deprecation warnings
- test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes
- test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes_with_empty_file
- )
-
- epytest
-}
diff --git a/dev-python/autopep8/autopep8-2.1.0.ebuild b/dev-python/autopep8/autopep8-2.1.0.ebuild
index 6a718a775d3f..1b82191667cc 100644
--- a/dev-python/autopep8/autopep8-2.1.0.ebuild
+++ b/dev-python/autopep8/autopep8-2.1.0.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm64 ~ia64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
RDEPEND="
>=dev-python/pycodestyle-2.11.0[${PYTHON_USEDEP}]