summaryrefslogtreecommitdiff
path: root/dev-python/autopep8/autopep8-1.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/autopep8/autopep8-1.7.0.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-1.7.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/autopep8/autopep8-1.7.0.ebuild b/dev-python/autopep8/autopep8-1.7.0.ebuild
new file mode 100644
index 000000000000..6ddc994a7a0e
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.9.1[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # test require in source build
+ test/test_autopep8.py::SystemTests::test_e101_skip_innocuous
+)