summaryrefslogtreecommitdiff
path: root/dev-python/autopep8/autopep8-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/autopep8/autopep8-1.6.0.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-1.6.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/autopep8/autopep8-1.6.0.ebuild b/dev-python/autopep8/autopep8-1.6.0.ebuild
index 2c892ed26d7e..ebe36cfed891 100644
--- a/dev-python/autopep8/autopep8-1.6.0.ebuild
+++ b/dev-python/autopep8/autopep8-1.6.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -26,3 +26,7 @@ RDEPEND="
dev-python/toml[${PYTHON_USEDEP}]"
distutils_enable_tests unittest
+
+PATCHES=(
+ "${FILESDIR}"/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
+)