summaryrefslogtreecommitdiff
path: root/dev-python/autopep8/autopep8-1.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/autopep8/autopep8-1.3.2.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-1.3.2.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/autopep8/autopep8-1.3.2.ebuild b/dev-python/autopep8/autopep8-1.3.2.ebuild
index d26545d20f21..704659d6b880 100644
--- a/dev-python/autopep8/autopep8-1.3.2.ebuild
+++ b/dev-python/autopep8/autopep8-1.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,11 +10,16 @@ inherit distutils-r1
DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
IUSE="test"
RDEPEND="