summaryrefslogtreecommitdiff
path: root/dev-python/autocommand/autocommand-2.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/autocommand/autocommand-2.2.2.ebuild')
-rw-r--r--dev-python/autocommand/autocommand-2.2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/autocommand/autocommand-2.2.2.ebuild b/dev-python/autocommand/autocommand-2.2.2.ebuild
new file mode 100644
index 000000000000..6cae5f6f33a5
--- /dev/null
+++ b/dev-python/autocommand/autocommand-2.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to create a command-line program from a function"
+HOMEPAGE="
+ https://github.com/Lucretiel/autocommand/
+ https://pypi.org/project/autocommand/
+"
+SRC_URI="
+ https://github.com/Lucretiel/autocommand/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest