summaryrefslogtreecommitdiff
path: root/dev-python/autobahn
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/autobahn')
-rw-r--r--dev-python/autobahn/Manifest3
-rw-r--r--dev-python/autobahn/autobahn-23.6.2.ebuild13
-rw-r--r--dev-python/autobahn/files/autobahn-23.6.2-pytest-asyncio.patch42
3 files changed, 54 insertions, 4 deletions
diff --git a/dev-python/autobahn/Manifest b/dev-python/autobahn/Manifest
index 85d2103ec4fb..388c41e8ec36 100644
--- a/dev-python/autobahn/Manifest
+++ b/dev-python/autobahn/Manifest
@@ -1,3 +1,4 @@
+AUX autobahn-23.6.2-pytest-asyncio.patch 1705 BLAKE2B 580b7721e899dfe1c9f48c7c90d626803d6af59c6878e363c793bedf9deef9f877de4f368bf380137bd609cd26243448ef075c2473eba39ebf2bdd990140f58c SHA512 d6e290b153a683c138f4df87c72906f19d17f73eb07b382a7b6a0cf106e2a505f0abe49e720a4af2ca37a37a21555d3da6ea4db5df232f1896bc9943e233e0f5
DIST autobahn-23.6.2.tar.gz 480814 BLAKE2B fb4a2e8510a51e2e70289d98eb54b3b06aba6e011eb8ad4ac2fb6e706d7be313f60a785a8366ff47500a6ad58f5645eedbeb4c831087ab531d8650129ec08c45 SHA512 5935203277d17aab3f80e6edf700ff173fe7e23622b9d2617f91e080f56b078f947f907289f008b5eb21b1346142274616baad4a36629f49dafe409d6fdb931a
-EBUILD autobahn-23.6.2.ebuild 3641 BLAKE2B 68a40a7319685cbf23a522d381e09e25fb8a2b7f98e4d10918b2da8ee2c3195e6e6fa620650ebad31b2d17931919aa4761b3771f36f47a5f1b1ea3088d476303 SHA512 2102697b639ae1162122e85bce2bfb41a612e7caf54b9a4b1890a81a0a2bbfbaebd2730c07db776ed0994c93c1366960ffbb00e0514f4f2189d10cd1d49d5049
+EBUILD autobahn-23.6.2.ebuild 3842 BLAKE2B 952b020001266cdcbb9711387aa47ea84501ae9e6c5a084f3411c4499da58c5c2d5cd4f58ee7ad61bb721c0141da08cb36a7871eb61a79eb2863c37399c999cf SHA512 ec3b22a0e56c7161fda265e8b9c061e0759730d7efdff9d38f3b3b09cdaa5546eb1ae1c0bb9818ad434496db9897ddda1ed3423cd18bd385c84e25ae9bd26a85
MISC metadata.xml 490 BLAKE2B 8a89cd7548ec88a59515e5dc51748571a789dfd3fa937ccb85cd17a2cde6e0852374cbc70a115a8dba7df4216e41de74c9e9bc561d53cf65799169078e540028 SHA512 1069d3412e87c310b6067e35bcfd4d54f4b944ab98948dfc5053831d62a41d9656fd127a9366ea432cd90c35ced1e8ed913783f1e9494ffba4a28a20fbc465b4
diff --git a/dev-python/autobahn/autobahn-23.6.2.ebuild b/dev-python/autobahn/autobahn-23.6.2.ebuild
index ac905597289a..de4ff8467e6d 100644
--- a/dev-python/autobahn/autobahn-23.6.2.ebuild
+++ b/dev-python/autobahn/autobahn-23.6.2.ebuild
@@ -11,13 +11,12 @@ inherit distutils-r1 optfeature pypi
DESCRIPTION="WebSocket and WAMP for Twisted and Asyncio"
HOMEPAGE="
- https://crossbar.io/autobahn/
https://github.com/crossbario/autobahn-python/
https://pypi.org/project/autobahn/
"
-SLOT="0"
LICENSE="MIT"
+SLOT="0"
KEYWORDS="amd64 arm arm64 ~riscv ~sparc x86"
IUSE="test xbr"
RESTRICT="!test? ( test )"
@@ -58,6 +57,11 @@ BDEPEND="
"
python_prepare_all() {
+ local PATCHES=(
+ # https://github.com/crossbario/autobahn-python/pull/1634
+ "${FILESDIR}/${P}-pytest-asyncio.patch"
+ )
+
if use xbr ; then
eerror "***************"
eerror "Required xbr dependencies are incomplete in Gentoo."
@@ -89,8 +93,11 @@ python_test() {
unset USE_TWISTED
einfo "RE-testing cryptosign and component_aio using asyncio"
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x USE_ASYNCIO=true
- epytest --pyargs autobahn.wamp.test.test_wamp_{cryptosign,component_aio}
+ epytest -p asyncio --pyargs \
+ autobahn.asyncio.test.test_aio_{raw,web}socket \
+ autobahn.wamp.test.test_wamp_{cryptosign,component_aio}
unset USE_ASYNCIO
rm -f twisted/plugins/dropin.cache || die
diff --git a/dev-python/autobahn/files/autobahn-23.6.2-pytest-asyncio.patch b/dev-python/autobahn/files/autobahn-23.6.2-pytest-asyncio.patch
new file mode 100644
index 000000000000..2cdbd863231b
--- /dev/null
+++ b/dev-python/autobahn/files/autobahn-23.6.2-pytest-asyncio.patch
@@ -0,0 +1,42 @@
+From 5ab94618723c488df640ae0777ac5a16ee1ab369 Mon Sep 17 00:00:00 2001
+From: David Hotham <david.hotham@microsoft.com>
+Date: Sat, 13 Apr 2024 05:27:01 +0100
+Subject: [PATCH] unit test fixes (#1634)
+
+---
+ autobahn/wamp/test/test_wamp_component_aio.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/autobahn/wamp/test/test_wamp_component_aio.py b/autobahn/wamp/test/test_wamp_component_aio.py
+index 168933ea5..2de9bf358 100644
+--- a/autobahn/wamp/test/test_wamp_component_aio.py
++++ b/autobahn/wamp/test/test_wamp_component_aio.py
+@@ -35,7 +35,7 @@
+
+ @pytest.mark.skipif(sys.version_info < (3, 5), reason="requires Python 3.5+")
+ @pytest.mark.asyncio(forbid_global_loop=True)
+- def test_asyncio_component(event_loop):
++ async def test_asyncio_component(event_loop):
+ orig_loop = txaio.config.loop
+ txaio.config.loop = event_loop
+
+@@ -72,11 +72,11 @@ def done(f):
+ txaio.config.loop = orig_loop
+ assert comp._done_f is None
+ f.add_done_callback(done)
+- return finished
++ await finished
+
+ @pytest.mark.skipif(sys.version_info < (3, 5), reason="requires Python 3.5+")
+ @pytest.mark.asyncio(forbid_global_loop=True)
+- def test_asyncio_component_404(event_loop):
++ async def test_asyncio_component_404(event_loop):
+ """
+ If something connects but then gets aborted, it should still try
+ to re-connect (in real cases this could be e.g. wrong path,
+@@ -151,4 +151,4 @@ def done(f):
+ finished.set_result(None)
+ txaio.config.loop = orig_loop
+ f.add_done_callback(done)
+- return finished
++ await finished