summaryrefslogtreecommitdiff
path: root/dev-python/asynctest/asynctest-0.12.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/asynctest/asynctest-0.12.2.ebuild')
-rw-r--r--dev-python/asynctest/asynctest-0.12.2.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/asynctest/asynctest-0.12.2.ebuild b/dev-python/asynctest/asynctest-0.12.2.ebuild
deleted file mode 100644
index 92996edd1fe1..000000000000
--- a/dev-python/asynctest/asynctest-0.12.2.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Enhance the standard unittest with features for testing asyncio libraries"
-HOMEPAGE="https://github.com/Martiusweb/asynctest/ https://pypi.org/project/asynctest/"
-SRC_URI="https://github.com/Martiusweb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-src_prepare() {
- default
-
- sed -i "{s/test_events_watched_outside_test_are_ignored/_&/}" "test/test_selector.py" || die "Could not disable the failing test."
-}
-
-python_test() {
- "${EPYTHON}" -m unittest -v test || die "Testing failed"
-}