summaryrefslogtreecommitdiff
path: root/dev-python/asyncssh/asyncssh-2.14.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/asyncssh/asyncssh-2.14.2.ebuild')
-rw-r--r--dev-python/asyncssh/asyncssh-2.14.2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/asyncssh/asyncssh-2.14.2.ebuild b/dev-python/asyncssh/asyncssh-2.14.2.ebuild
index 1ad40f7b2969..0c7015523b72 100644
--- a/dev-python/asyncssh/asyncssh-2.14.2.ebuild
+++ b/dev-python/asyncssh/asyncssh-2.14.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 optfeature pypi
@@ -35,11 +35,12 @@ BDEPEND="
)
"
-EPYTEST_DESELECT=(
- # https://github.com/ronf/asyncssh/pull/578
- tests/test_process.py::_TestAsyncFileRedirection::test_stdout_aiofile
+PATCHES=(
+ # https://github.com/ronf/asyncssh/issues/616
+ "${FILESDIR}/${P}-py313.patch"
)
+EPYTEST_XDIST=1
distutils_enable_tests pytest
distutils_enable_sphinx docs