summaryrefslogtreecommitdiff
path: root/dev-python/async_timeout/async_timeout-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/async_timeout/async_timeout-1.2.0.ebuild')
-rw-r--r--dev-python/async_timeout/async_timeout-1.2.0.ebuild27
1 files changed, 0 insertions, 27 deletions
diff --git a/dev-python/async_timeout/async_timeout-1.2.0.ebuild b/dev-python/async_timeout/async_timeout-1.2.0.ebuild
deleted file mode 100644
index 375a1916976e..000000000000
--- a/dev-python/async_timeout/async_timeout-1.2.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{5,6} )
-
-inherit distutils-r1
-
-MY_P=${PN/_/-}-${PV}
-DESCRIPTION="Timeout context manager for asyncio programs"
-HOMEPAGE="https://github.com/aio-libs/async_timeout/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-S=${WORKDIR}/${MY_P}
-
-DEPEND="dev-python/pytest-runner[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? ( dev-python/pytest-aiohttp[${PYTHON_USEDEP}] )"
-
-python_test() {
- esetup.py test || die
-}