summaryrefslogtreecommitdiff
path: root/dev-python/async_generator/async_generator-1.10-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/async_generator/async_generator-1.10-r1.ebuild')
-rw-r--r--dev-python/async_generator/async_generator-1.10-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/async_generator/async_generator-1.10-r1.ebuild b/dev-python/async_generator/async_generator-1.10-r1.ebuild
new file mode 100644
index 000000000000..1e7a3a023087
--- /dev/null
+++ b/dev-python/async_generator/async_generator-1.10-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Making it easy to write async iterators in Python 3.5"
+HOMEPAGE="https://github.com/python-trio/async_generator https://pypi.org/project/async_generator/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ pushd "${BUILD_DIR}/lib" >/dev/null || die
+ epytest
+ rm -rf .hypothesis .pytest_cache || die
+ popd >/dev/null || die
+}