summaryrefslogtreecommitdiff
path: root/dev-python/async_generator/async_generator-1.10-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/async_generator/async_generator-1.10-r1.ebuild')
-rw-r--r--dev-python/async_generator/async_generator-1.10-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/async_generator/async_generator-1.10-r1.ebuild b/dev-python/async_generator/async_generator-1.10-r1.ebuild
index c0f0e694ff3b..bbf73500c2c5 100644
--- a/dev-python/async_generator/async_generator-1.10-r1.ebuild
+++ b/dev-python/async_generator/async_generator-1.10-r1.ebuild
@@ -13,8 +13,13 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
DOCS=( README.rst )
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}