summaryrefslogtreecommitdiff
path: root/dev-python/astroid
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest2
-rw-r--r--dev-python/astroid/astroid-2.12.13.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 7d61e69427a0..50815d324139 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,3 +1,5 @@
DIST astroid-2.12.12.gh.tar.gz 437277 BLAKE2B a1f549db526b1012e76e1da480e779a35971e8985f452eaf5ce1bc6735c5210db5c2282685dbaa2f1720a1e1fa6cf6f2152fbb8c782243cd11e09acc427774da SHA512 61047c1aa31b5b0a80c604194a91341c474062e2f1094316ff9b03641ecfe3ddf25b4a3b26356561f9c16d8b5599694ecef275ce5846792a18bcc0a7ad3e720f
+DIST astroid-2.12.13.gh.tar.gz 437906 BLAKE2B c00462d44c9705dc5b46fc52915e6a44e53e840d5326427d235c9156bc4de58b184271338ebc10a4572e1aace8d4ababd3bd7e440a6ee585aa66d15dfe4117be SHA512 16d062b1a619663b157c4753f1744e56e7d0ef7cace12660feb7f6bc540e54be02638b52c1c877d3eb514e2d7423c4afc71e7d5464880bfd3724ff7ae6d7b90a
EBUILD astroid-2.12.12.ebuild 1809 BLAKE2B 989055cbea9fa3c74f80b54efe69005c1d9f802aa9c0b6c91105ed77dbafd3406e955e98c4acd8b51a5dfc5126bcef001fa00a8d6dce186cb8011ffcb1cd7a07 SHA512 46c0adf7b503d3716baadad6fc9fb1fe61dff5ca4e11c5225354cdd57b0afb1a05e66a8650dff8e76fdd45062e16ba89c639e24405238c175e6e715b4a3a313f
+EBUILD astroid-2.12.13.ebuild 1817 BLAKE2B 8e495b2ba1a5ba50cd82944562d02f279cb9915cff1487ae13e3d752f0341213cb2be6b7a0ad3c88c9a0e09258c8b007ee557fdccfe821fb38d818015a141030 SHA512 18156ef33b1c5bde959cad1afc1309435eec1049e631edece13070713988d76b9ebe5574a15d64fd3098e62a7d74c3c3d6c1ebf500f6811aa7f76d35389d2617
MISC metadata.xml 1143 BLAKE2B 1f6c4e004277eebed2e29cb935ef01e5f18fb0a526f99f0e875ae3815308dce0483b5274b4e23bed076464aa62a035937a7a3817e2d4a5fb9211b9043271e04c SHA512 56b07d0f08a49772661bc3d233cf1f628aa7c241c51b91d75dfbd44995e169d8ab5bbd99863d7b9b67792486346982a7b8eebefb462e7e212cd7dff920d80840
diff --git a/dev-python/astroid/astroid-2.12.13.ebuild b/dev-python/astroid/astroid-2.12.13.ebuild
new file mode 100644
index 000000000000..a7561581a64c
--- /dev/null
+++ b/dev-python/astroid/astroid-2.12.13.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/PyCQA/astroid/
+ https://pypi.org/project/astroid/
+"
+SRC_URI="
+ https://github.com/PyCQA/astroid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in pyproject.toml
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.10[${PYTHON_USEDEP}]
+ <dev-python/wrapt-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # no clue why it's broken
+ tests/unittest_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ tests/unittest_brain_dataclasses.py::test_pydantic_field
+ tests/unittest_brain.py::SixBrainTest::test_from_imports
+ tests/unittest_regrtest.py::NonRegressionTests::test_numpy_distutils
+ # some problem with warnings (our options?)
+ tests/unittest_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
+ tests/unittest_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
+ tests/unittest_scoped_nodes.py::test_deprecation_of_doc_attribute
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker
+}