summaryrefslogtreecommitdiff
path: root/dev-python/astroid
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astroid')
-rw-r--r--dev-python/astroid/Manifest2
-rw-r--r--dev-python/astroid/astroid-2.15.8-r1.ebuild68
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index 48a8fa69a04c..591dd2390e73 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1,5 +1,3 @@
-DIST astroid-2.15.8.gh.tar.gz 462922 BLAKE2B 6a4bf0a50333701aab9282ab126fc53d30621d4e7a54796ac93d1db30bc37098d5409f3ffe91ed279bce5866e2e381eafc7f54f18c86aa3a7fc835f0bf844d9a SHA512 d5d008df3e99c036fb38094c416c080745dad640d46e837b07336a23d5a929823b8b884564486600335791a1be0568cbe519b76e6bd3334e72725966af8cc5f5
DIST astroid-3.0.1.gh.tar.gz 461593 BLAKE2B de3458bcd9ba111020132e89b6e2fdf18b81b82cba68c986e84af91c910e6c70e7d13ff024b7947f3fa08e2491ba211a77a35421b3d5cd184b94e6a833c0da42 SHA512 2c8a4cf22959aef1eb9510430bcc55d00fcda76d022575786c9a59c093fe4196b67c0b9401f9226595a4cbf1fb9444bdfbb9ac2d83c115ec1d7d46cb7dd75dbd
-EBUILD astroid-2.15.8-r1.ebuild 2178 BLAKE2B 64416182742c1f0b64f0170f175725d7fe1d69bcc26490a853f66ad61f4e568fbe4ddde9a712ffef890440a683c53162c898533de0ae30855dfe497b329d8326 SHA512 e315f0c71ae4dbbe2ff815488418fe665f4ae8092b4f966e021a624b833434a4cf0ab854733727df3c6341065239e84f877afb7794283efacb82968190a49762
EBUILD astroid-3.0.1.ebuild 2122 BLAKE2B eb6804b48fc3cb893998362cbc71d8e7b4f26733d5d2215f31c2eedb28bd975c132d36183ec1ae68cd89b17bec5d2df260ce293c1b5c92d2048a18f01534949d SHA512 517c22bd91df04e276236c44711197c34e72257c000c69ea67484a1d628b31ca9c406ca668a49faa823c48df4578c0426f5a5f78a90873cd3ad5515df2759325
MISC metadata.xml 1148 BLAKE2B 29a6cfc0c292117920be154d37ed4770f1fb1679186576fe6151cc02d1d6be766045e0231e2fceb87cbd250dbed3888c99b7ca7dc0182cc700a11961d9cd6d9e SHA512 6821d13f5e82bd73ee4fd165c0b4c94f40cd6af536dee1658cccb4175e67da2611c4d1478cdef1607535f23224116ad482197e0b0eef8f0a94d596bf250b3074
diff --git a/dev-python/astroid/astroid-2.15.8-r1.ebuild b/dev-python/astroid/astroid-2.15.8-r1.ebuild
deleted file mode 100644
index b99d5fc94b06..000000000000
--- a/dev-python/astroid/astroid-2.15.8-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="
- https://github.com/pylint-dev/astroid/
- https://pypi.org/project/astroid/
-"
-SRC_URI="
- https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# Version specified in pyproject.toml
-RDEPEND="
- >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
- <dev-python/wrapt-2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
- ' 3.9 3.10)
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # no clue why they're broken
- tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
- tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
- tests/brain/test_regex.py::TestRegexBrain::test_regex_pattern_and_match_subscriptable
- # some problem with warnings (our options?)
- tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
- tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
- tests/test_scoped_nodes.py::test_deprecation_of_doc_attribute
- # requires six bundled in urllib3, sigh
- tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
- # requires pip, and looks suspicious anyway
- tests/test_manager.py::IsolatedAstroidManagerTest::test_no_user_warning
- # pydantic-2?
- tests/brain/test_dataclasses.py::test_pydantic_field
- # TODO
- tests/test_manager.py::ClearCacheTest::test_clear_cache_clears_other_lru_caches
- )
-
- # Faker causes sys.path_importer_cache keys to be overwritten
- # with PosixPaths
- epytest -p no:faker
-}