summaryrefslogtreecommitdiff
path: root/dev-python/astroid/files/astroid-2.4.2-no-pytest-runner.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astroid/files/astroid-2.4.2-no-pytest-runner.patch')
-rw-r--r--dev-python/astroid/files/astroid-2.4.2-no-pytest-runner.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/astroid/files/astroid-2.4.2-no-pytest-runner.patch b/dev-python/astroid/files/astroid-2.4.2-no-pytest-runner.patch
new file mode 100644
index 000000000000..cae04e05a33c
--- /dev/null
+++ b/dev-python/astroid/files/astroid-2.4.2-no-pytest-runner.patch
@@ -0,0 +1,21 @@
+diff --git a/setup.py b/setup.py
+index 016fce18..a6825d8b 100644
+--- a/setup.py
++++ b/setup.py
+@@ -30,8 +30,6 @@ with open(os.path.join(astroid_dir, "README.rst")) as fobj:
+
+
+ needs_pytest = set(["pytest", "test", "ptr"]).intersection(sys.argv)
+-pytest_runner = ["pytest-runner"] if needs_pytest else []
+-
+
+ def install():
+ return setup(
+@@ -48,7 +46,6 @@ def install():
+ install_requires=install_requires,
+ extras_require=extras_require,
+ packages=find_packages(exclude=["tests"]) + ["astroid.brain"],
+- setup_requires=pytest_runner,
+ test_suite="test",
+ tests_require=["pytest"],
+ )