summaryrefslogtreecommitdiff
path: root/dev-python/astor/astor-0.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astor/astor-0.7.1.ebuild')
-rw-r--r--dev-python/astor/astor-0.7.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/astor/astor-0.7.1.ebuild b/dev-python/astor/astor-0.7.1.ebuild
new file mode 100644
index 000000000000..39071f8adc5e
--- /dev/null
+++ b/dev-python/astor/astor-0.7.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Read/rewrite/write Python ASTs"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="https://pypi.org/project/astor/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ #avoid file collisions picked up by the eclass
+ sed -e s":find_packages():find_packages(exclude=['tests']):" -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "tests failed under ${EPYTHON}"
+}