summaryrefslogtreecommitdiff
path: root/dev-python/asn1crypto/asn1crypto-0.24.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/asn1crypto/asn1crypto-0.24.0.ebuild')
-rw-r--r--dev-python/asn1crypto/asn1crypto-0.24.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/asn1crypto/asn1crypto-0.24.0.ebuild b/dev-python/asn1crypto/asn1crypto-0.24.0.ebuild
new file mode 100644
index 000000000000..396fcf0d0489
--- /dev/null
+++ b/dev-python/asn1crypto/asn1crypto-0.24.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python ASN.1 library with a focus on performance and a pythonic API"
+HOMEPAGE="https://github.com/wbond/asn1crypto/ https://pypi.python.org/pypi/asn1crypto/"
+# pypi tarball does not have tests
+SRC_URI="https://github.com/wbond/asn1crypto/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x64-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}