summaryrefslogtreecommitdiff
path: root/dev-python/asgiref/asgiref-3.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/asgiref/asgiref-3.8.1.ebuild')
-rw-r--r--dev-python/asgiref/asgiref-3.8.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/asgiref/asgiref-3.8.1.ebuild b/dev-python/asgiref/asgiref-3.8.1.ebuild
new file mode 100644
index 000000000000..7b91be9aa018
--- /dev/null
+++ b/dev-python/asgiref/asgiref-3.8.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ASGI utilities (successor to WSGI)"
+HOMEPAGE="
+ https://asgi.readthedocs.io/en/latest/
+ https://github.com/django/asgiref/
+ https://pypi.org/project/asgiref/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest